Phonely

Call History Page is not loading
Resolved·Degraded performance

Users should see the calls loading correctly, we've deployed a fix for this issue.

Wed, Nov 5, 2025, 06:21 PM
(2 days ago)
·
Affected components
Website
Updates

Resolved

Users should see the calls loading correctly, we've deployed a fix for this issue.

Wed, Nov 5, 2025, 06:21 PM

Monitoring

Some customers have reported that the Call History page is not loading the calls. We've found an issue with the underlying connection issue, and have rolled in a fix. Users should see the calls loading correctly now. Calls were not affected by this issue.

Wed, Nov 5, 2025, 06:20 PM
Powered by